VMWare SDK et certificat par défaut

Lors de la création d’une instance de XenDesktop, j’ai eu une erreur me signifiant que le serveur VCenter n’était pas accessible. Après avoir vérifier les erreurs de débutant (credentials, etc.), j’ai entré l’URL dans un navigateur. Evidemment, j’ai rencontré l’erreur de certificat traditionnelle. En acceptant le certificat non reconnu, la page apparaît bien et je peux ouvrir le certificat.

détail du certificat VCenter

Là où ça devient drôle, c’est que même en suivant les instructions de Jarian Gibson http://jariangibson.com/2009/10/13/using-xendesktop-with-vmware/  en installant le certificat dans le magasin du serveur XenDesktop (Trusted Root et Trusted People) j’ai toujours l’erreur relative au certificat dans IE :

Erreur de certificat IE

Solution :

Le certificat a été émis pour NFR-VCENTER et non pas pour NFR-VCENTER.lab.nelite.com.

La solution est :

  • d’installer le certificat dans les Trusted people du magasin Computer (apparemment, pas nécessaire de les installer dans les Trusted Root)
  • N’appeler le serveur en mode https que par son nom court et pas son FQDN !

Je poste ici car j’ai l’impression que ça n’a posé de problème à personne… Ou Google n’est plus mon ami 😦

Advertisements

Citrix, mobility & virtualization @Work / father, husband & geek @home

Tagged with: , , ,
Posted in Virtualisation
5 comments on “VMWare SDK et certificat par défaut
  1. Rotam says:

    Bonjour,

    Je te rassure, j’ai eu le même soucis 😉

    Et rajouter le certif dans les trusted people n’a pas résolu mon affaire xd
    Je vais surement trouver la solution 😛

    Rotam

  2. jeromequief says:

    @Rotam : as-tu bien mis le certificat dans les trusted People du magasin ordinateur ? https://SERVEUR/sdk/vimservice.wsdl devrait t’aider à valider. Vérifie bien dans le champ “subject alternative name” de ton certificat que tu as bien le nom de ton serveur. C’est ce nom que tu dois appeler. Dans mon cas, le serveur a été renommé et je suis obligé de conserver l’ancien nom dans mon DNS pour que cela fonctionne.

  3. Rotam says:

    @ jeromequief

    J’ai correctement rajouté le certificat,
    Le problème est que l’installation de l’ESXi n’a pas été faite par moi, et que je n’arrive pas à pointer vers le répertoire /sdk qui devrait pourtant exister par défaut. J’arrive correctement sur la page d’accueil de l’ESXi (Getting Started) mais le navigateur ne parvient pas à trouver le répertoire SDK.
    Je bute sur cette difficulté depuis quelques jours, et c’est quelque peu rageant 🙂
    Du coup, toute mon installation est en stand by, en attendant de régler le problème de ce répertoire fantôme, et de ce certificat SSL qui ne veut pas s’installer correctement

    Cdt

    Rotam

    • jeromequief says:

      On n’accède pas au répertoire sdk. Ca ne fonctionne pas avec un navigateur car il attend des requêtes SOAP. On peut tester en ajoutant /vimservice.wsdl uniquement. Le dossier sur le vCenter c’est “C:\ProgramData\VMware\VMware VirtualCenter\docRoot\sdk” (sur 2008 R2, sinon dans AllUsers). Normalement installé en standard mais il te faut des licences $$$ (entreprise je crois).

  4. Rotam says:

    Mon repertoire sdk existe bel et bien (!!!!) (fichier caché)
    J’ai fais la manip dans proxy.xml, et cela fonctionne xd

    Merci de ta patience

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: